升级到macOS High Sierra Pod不能执行的解决办法

macOS 升级到 High Sierra 后,执行pod命令出错,出错信息如下:

1
2
JUNSHAO-MC0:~ junshao$ pod
-bash: /usr/local/bin/pod: /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/bin/ruby: bad interpreter: No such file or directory

解决办法是重装cocoapods

1
2
sudo gem uninstall cocoapods
sudo gem install -n /usr/local/bin cocoapods